Follow

What are the requirements for iMindMap Plus Mobile apps and web apps?

 

iMindMap and iMindMap HD for iOS

  • iOS 6.0 and up

iMindMap web application at http://app.iMindMap.com

  • Supported in the following browsers: Firefox, Chrome, Safari, and IE8 and higher
  • You must have Adobe Flash installed to edit maps online
  • Cookies and JavaScript must be enabled
Have more questions? Submit a request

Back to Help Centre

Powered by Zendesk